Bot is working but not fully

Advanced automation available in Guardian - Chat with others and share files here.
Post Reply
BigJ
Posts: 45
Joined: Fri Jun 23, 2017 10:33 am

Mon Oct 09, 2017 8:53 pm

Hi All

I have a back bot at BSP working but it's not back all horses which qualify. As an example if there are 4 qualifying horses in a race it will only back two of them.

The bot is set to trigger 10 times once every 2 seconds until 20 seconds after the event goes in play. I have a "number of place bets trigger condition set, so In theory this should trigger 10 times covering up to 10 horses different horses. Looking back over the automation results none have triggered 10 times in fact the most it triggered for all races was 4 times out of 10.

Can anyone explain why this would happen?

Cheers

User avatar
Dallas
Posts: 5597
Joined: Sun Aug 09, 2015 10:57 pm

Tue Oct 10, 2017 1:19 pm

Have you double checked all are applied correctly that includes any conditions being used?
(ie you dont have some applied to order of and other by row index)

BigJ
Posts: 45
Joined: Fri Jun 23, 2017 10:33 am

Tue Oct 10, 2017 3:51 pm

Hi Dallas

Yes checked and all are set correctly.

Thanks

Jordan

User avatar
Dallas
Posts: 5597
Joined: Sun Aug 09, 2015 10:57 pm

Tue Oct 10, 2017 9:49 pm

What about your guardian setting? what refresh rate are you using?

Have a read through this thread which explains guardian cycling/refreshing - if you have this too slow and/or alot of markets loaded then it could be the cause
viewtopic.php?f=37&t=11491

BigJ
Posts: 45
Joined: Fri Jun 23, 2017 10:33 am

Wed Oct 11, 2017 8:34 pm

Got one set to 500ms and on the gaurdian page set to 200ms. Have put them both at 200ms. Have also played around with the trigger setting and given it more time which seems to have worked. Will keep an eye on it but as always thanks for your help.

Cheers

BigJ
Posts: 45
Joined: Fri Jun 23, 2017 10:33 am

Fri Oct 13, 2017 7:29 pm

Dallas wrote:
Tue Oct 10, 2017 9:49 pm
What about your guardian setting? what refresh rate are you using?

Have a read through this thread which explains guardian cycling/refreshing - if you have this too slow and/or alot of markets loaded then it could be the cause
viewtopic.php?f=37&t=11491
Hi Dallas

My bot is still not working properly. Can you see any reason as to why it wouldn't work? I i've set it to trigger 12 times so I can cover up to 12 horses bu realistically I will only cover up to 5 or 6

It does trigger but will only ever cover one or two horses even if more qulify

Appreciate any pointers you can give it's driving me insane

Bot file attached.

Essentially i'm looking to back all horses with an BSP less that 10 and more that 5.5. Appreciate the odd fluctuate at the start but regardless of the fluctuation if the BSP is between the stated I want to back the horse.

Thanks

Jordan
You do not have the required permissions to view the files attached to this post.

User avatar
Dallas
Posts: 5597
Joined: Sun Aug 09, 2015 10:57 pm

Fri Oct 13, 2017 8:36 pm

Just tried it on last 3 races and its worked fine on them all,

1st had 5 out of 5 match
2nd also had 5 out of matched even though i didn't switch to market till a few secs after start
3rd i changed the cond to <35 and it still trigger on 10 of 10 qualifying runners
You do not have the required permissions to view the files attached to this post.

BigJ
Posts: 45
Joined: Fri Jun 23, 2017 10:33 am

Fri Oct 13, 2017 8:59 pm

Dallas wrote:
Fri Oct 13, 2017 8:36 pm
Just tried it on last 3 races and its worked fine on them all,

1st had 5 out of 5 match
2nd also had 5 out of matched even though i didn't switch to market till a few secs after start
3rd i changed the cond to <35 and it still trigger on 10 of 10 qualifying runners
Thanks Dallas -

I don't what to say :roll:. there have definitely been times when it doesn't back all the horses that it should but if you say it works then I will stick with i.

Can you think of any reasons why it would work all be it sporadically? Maybe price volatility? I.e if bsp is 6.0 but it falls straight below 5.5 before it can be matched?

Cheers

nothin

BigJ
Posts: 45
Joined: Fri Jun 23, 2017 10:33 am

Fri Oct 13, 2017 9:00 pm

BigJ wrote:
Fri Oct 13, 2017 8:59 pm
Dallas wrote:
Fri Oct 13, 2017 8:36 pm
Just tried it on last 3 races and its worked fine on them all,

1st had 5 out of 5 match
2nd also had 5 out of matched even though i didn't switch to market till a few secs after start
3rd i changed the cond to <35 and it still trigger on 10 of 10 qualifying runners
Thanks Dallas -

I don't what to say :roll:. there have definitely been times when it doesn't back all the horses that it should but if you say it works then I will stick with i.

Can you think of any reasons why it would work all be it sporadically? Maybe price volatility? I.e if bsp is 6.0 but it falls straight below 5.5 before it can be matched?

Cheers

nothin
*meant to say would't work all be it sporadically :) also didn't mean to put nothin.

User avatar
Dallas
Posts: 5597
Joined: Sun Aug 09, 2015 10:57 pm

Fri Oct 13, 2017 9:23 pm

There's never a guarantee of getting one matched, a horse could fly off at the start and romp home and not trade anywhere near or above its BSP to match your bet, and the last of your bets aren't going in for up to 25 secs.

But they should at least all trigger if there BSP are between the prices you have set.

The only reason for none triggers would be a connection issue/market refreshing to slow in guardian but im sure you've said previously these are set quick enough

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests